[phpBB] Lintian warnings, ${misc:Depends} or not ?

J.M.Roth jmroth at iip.lu
Wed Mar 17 23:10:00 CET 2010


Hi there,

On 3/17/2010 10:32 PM, David Prévot wrote:
> In 475, I added ${misc:Depends} as a dependency for phpbb3-l10n because
> Lintian warned me about "debhelper-but-no-misc-depends".
> In 476, you revert this change, noticing that dh_gencontrol throws a
> warning: "warning: unknown substitution variable ${misc:Depends}", so it
> doesn't substitute it anyhow.

I thought I had read somewhere that one should not add what is supposed
to be there anyhow (because of the higher-up dependency). Unfortunately
I have no reference for that right now.

> I can't see this warning (either with "debuild -i -us -uc", "sudo
> cowbuilder --build phpbb3_3.0.7-PL1-1.dsc" or "sudo pbuilder build
> phpbb3_3.0.7-PL1-1.dsc").
> 
> Is there anything I made wrong, can I make the build more verbose ?

I dunno if you did something wrong. Probably neither of us made
something wrong.
I see there is http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=498666.
So if I understand correctly the warning is gone in your version because
it is probably set to empty. Can you check? In that case one wouldn't
need to specify it anyhow since the dependencies between our two
packages are quite clear ;-)

> Note that I work with an up to date Sid, if that matters.

I guess that (again) seems to be the culprit.
What release *should* one use to do the development work anyhow?

> About Lintian warnings, does database_update_debian.php really needs to
> start with "#!" ? 

Oh yes it definitely does because dbcommon-config calls it and there is
no other way for me to specify what should be the interpreter.

> If it does, it would probably would make sens to make
>> it executable.

Well we could add the exception to Lintian or make it executable. I'll
flip a coin ;-)

Greetings

JM




More information about the phpBB-l mailing list