[phpBB] I did not think this was so hard ;-)

J.M.Roth jmroth at iip.lu
Thu Mar 18 23:45:47 CET 2010


I have done some final(?) changes.

As you may have noticed, I have also committed the
"3.0.7-PL1-1_dbcmulti-xp" branch which I use to play with
dbconfig-common and multisite behavior. I believe this is still way too
experimental to go into any kind of official release. However, feel free
to "check it out"...
CAUTION: Better not interrupt debuild! I'm including functions for
dbconfig-multisite using sed (see the rules file) via the
#DBC_MULTISITE_INC# anchor in several maintainer scripts. I know it's
not so cool but there I didn't see a cleaner way here.

Now as far as the actual "official" update is concerned:

Things to do when checking the new package (trunk):
- install 3.0.7-PL1-1 using all 3 kinds of DBs, and check if it
works[tm] on your system,
- install 3.0.2-4 in mysql and pgsql modes, upgrade to 3.0.7-PL1-1, and
check if it works[tm] (install 3.0.2-4 in sqlite mode is broken anyway,
so there is no upgrade path here),

where "check if it works[tm]" means obviously:
- check if the forum (and the admin panel) actually loads without errors
in the browser (make sure to empty the browser cache)
- if you have a running forum, even better: back it up and try the
upgrade and see if smilies, avatars etc. are still there and everything
else works too (file uploads etc.)
Don't believe in me too much and be prepared that the upgrade destroys
everything, so I reiterate the need to backup and possibly not yet use
this package on a live site, but I guess you knew that already.

Greetings

JM




More information about the phpBB-l mailing list